GetFluidTemperature Method


Gets the fluid temperature of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public double GetFluidTemperature(
	FabricationService service
)
Visual Basic
Public Function GetFluidTemperature ( _
	service As FabricationService _
) As Double
Visual C++
public:
double GetFluidTemperature(
	FabricationService^ service
)

Parameters

service
Type: Autodesk.Revit.DBFabricationService
The service to lookup.

Return Value

The temperature in Kelvin.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException service is not mapped to a fluid type and temperature.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also