Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document in which the new wall is created.
- profile
- Type: System.Collections.GenericIListCurve
An array of planar curves that represent the vertical profile of the wall.
- wallTypeId
- Type: Autodesk.Revit.DBElementId
Id of the wall type to be used by the new wall instead of the default type.
- levelId
- Type: Autodesk.Revit.DBElementId
Id of the level on which the wall is to be placed.
- structural
- Type: SystemBoolean
If set, specifies that the wall is structural in nature.
- normal
- Type: Autodesk.Revit.DBXYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.
Return Value
If successful a new wall object within the project.Examples

public Wall CreateWallUsingProfile(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
// Build a wall profile for the wall creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(20, 0, 0);
XYZ third = new XYZ(20, 0, 15);
XYZ fourth = new XYZ(0, 0, 15);
IList<Curve> profile = new List<Curve>();
// Get application creation object
Autodesk.Revit.Creation.Application appCreation = document.Application.Create;
profile.Add(Line.CreateBound(first, second));
profile.Add(Line.CreateBound(second, third));
profile.Add(Line.CreateBound(third, fourth));
profile.Add(Line.CreateBound(fourth, first));
XYZ normal = new XYZ(0, 1, 0);
// Create a wall
return Wall.Create(document, profile, wallType.Id, level.Id, true, normal);
}

Public Function CreateWallUsingProfile(document As Autodesk.Revit.DB.Document, level As Level, wallType As WallType) As Wall
' Build a wall profile for the wall creation
Dim first As New XYZ(0, 0, 0)
Dim second As New XYZ(20, 0, 0)
Dim third As New XYZ(20, 0, 15)
Dim fourth As New XYZ(0, 0, 15)
Dim profile As IList(Of Curve) = New List(Of Curve)()
' Get application creation object
Dim appCreation As Autodesk.Revit.Creation.Application = document.Application.Create
profile.Add(Line.CreateBound(first, second))
profile.Add(Line.CreateBound(second, third))
profile.Add(Line.CreateBound(third, fourth))
profile.Add(Line.CreateBound(fourth, first))
Dim normal As New XYZ(0, 1, 0)
' Create a wall
Return Wall.Create(document, profile, wallType.Id, level.Id, True, normal)
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input profile contains at least one helical curve and is not supported for this operation. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Failed to create the wall. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |