SetHost Method


Sets the reinforcement element that will be represented by the input bending detail.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static void SetHost(
	Element bendingDetail,
	Reference reference
)
Visual Basic
Public Shared Sub SetHost ( _
	bendingDetail As Element, _
	reference As Reference _
)
Visual C++
public:
static void SetHost(
	Element^ bendingDetail, 
	Reference^ reference
)

Parameters

bendingDetail
Type: Autodesk.Revit.DBElement
The bending detail for which we want to set the host.
reference
Type: Autodesk.Revit.DBReference
Reference pointing to the reinforcement element that will be represented by the input bending detail.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also