AsString Method


Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AsString(
	FamilyParameter familyParameter
)
Visual Basic
Public Function AsString ( _
	familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsString(
	FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DBFamilyParameter

Return Value

The string contained in the parameter. Returns a null reference (Nothing in Visual Basic) if the storage type of the input argument is not string type or this parameter has no value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument-"familyParameter"-is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown if the input argument-"familyParameter"-is invalid,

See Also