AsString Method


Family Type As String Method

Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string AsString(
	FamilyParameter familyParameter
)

Parameters

familyParameter FamilyParameter

Return Value

String
The string contained in the parameter. Returns if the storage type of the input argument is not string type or this parameter has no value.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument-"familyParameter"-is .
ArgumentException Thrown if the input argument-"familyParameter"-is invalid,
See Also