Adds a new item to the ComboBox.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- memberData
- Type: Autodesk.Revit.UIComboBoxMemberData
An object containing the data needed to construct the ComboBoxMember.
Return Value
The newly added ComboBoxMember.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when memberData is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when button with memberData.Name already exists in the drop-down list. |