AddItem Method


Combo Box Add Item Method

Adds a new item to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ComboBoxMember AddItem(
	ComboBoxMemberData memberData
)

Parameters

memberData ComboBoxMemberData
An object containing the data needed to construct the ComboBoxMember.

Return Value

ComboBoxMember
The newly added ComboBoxMember.
Exceptions
Exception Condition
ArgumentNullException Thrown when memberData is .
ArgumentException Thrown when button with memberData.Name already exists in the drop-down list.
See Also