Given a reference that represents a part of a bar, this method will return the bar index.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barReference
- Type: Autodesk.Revit.DBReference
The Reference of the Rebar element.
Return Value
The bar index the reference refers to.Remarks
The method returns an index between 0 and NumberOfBarPositions - 1 if it the given reference represents a part of a bar. Otherwise will return -1.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |