Rebar Get |
Given a reference that represents a part of a bar, this method will return the bar index.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- barReference Reference
- The Reference of the Rebar element.
Return Value
Int32The bar index the reference refers to.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The method returns an index between 0 and NumberOfBarPositions - 1 if it the given reference represents a part of a bar. Otherwise will return -1.