CheckFamily Method


Check that the loaded family has its content document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool CheckFamily(
	Document ADoc,
	ElementId familyId
)
Visual Basic
Public Shared Function CheckFamily ( _
	ADoc As Document, _
	familyId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckFamily(
	Document^ ADoc, 
	ElementId^ familyId
)

Parameters

ADoc
Type: Autodesk.Revit.DBDocument
The host document.
familyId
Type: Autodesk.Revit.DBElementId
The id of the family to check.

Return Value

Returns true if the family has its content document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also