CanConnectToUpstreamNode Method


Verifies that the area based load can connect to the upstream electrical analytical node. If the area based load already has an upstream node or the upstream node is full of downstream nodes, the area based load can't connect to the upstream node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public bool CanConnectToUpstreamNode(
	ElementId upstreamNodeId
)
Visual Basic
Public Function CanConnectToUpstreamNode ( _
	upstreamNodeId As ElementId _
) As Boolean
Visual C++
public:
bool CanConnectToUpstreamNode(
	ElementId^ upstreamNodeId
)

Parameters

upstreamNodeId
Type: Autodesk.Revit.DBElementId
The upstream electrical analytical node id.

Return Value

True if the area based load can connect to the upstream electrical analytical node.

Remarks

If the area based load supplies from Node A, Node A is the upstream node of the area based load, and the area based load is the downstream node of node A.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also