CanConnectToUpstreamNode Method


Area Based Load Data Can Connect To Upstream Node Method

Verifies that the area based load can connect to the upstream electrical analytical node. If the area based load already has an upstream node or the upstream node is full of downstream nodes, the area based load can't connect to the upstream node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanConnectToUpstreamNode(
	ElementId upstreamNodeId
)

Parameters

upstreamNodeId ElementId
The upstream electrical analytical node id.

Return Value

Boolean
True if the area based load can connect to the upstream electrical analytical node.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the area based load supplies from Node A, Node A is the upstream node of the area based load, and the area based load is the downstream node of node A.
See Also