Splits the straight into two at the passed in point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- partId
- Type: Autodesk.Revit.DBElementId
Identifier of the straight to split.
- position
- Type: Autodesk.Revit.DBXYZ
The position to split in the straight.
Return Value
Returns the element identifier of the new straight.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The part is not a straight. -or- The position is not on the straight. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |