SplitStraight Method


Fabrication Part Split Straight(Document, Element Id, XYZ) Method

Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId SplitStraight(
	Document document,
	ElementId partId,
	XYZ position
)

Parameters

document Document
The document.
partId ElementId
Identifier of the straight to split.
position XYZ
The position to split in the straight.

Return Value

ElementId
Returns the element identifier of the new straight.
Exceptions
Exception Condition
ArgumentException The part is not a straight. -or- The position is not on the straight.
ArgumentNullException A non-optional argument was null
See Also