Constructs an instance of FilterDoubleRule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- valueProvider
- Type: Autodesk.Revit.DBFilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
- evaluator
- Type: Autodesk.Revit.DBFilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
- ruleValue
- Type: SystemDouble
The user-supplied value against which values from a Revit document will be tested.
- epsilon
- Type: SystemDouble
The tolerance within which two floating-point values may be considered equal.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value for ruleValue is not finite -or- The given value for ruleValue is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |