Filter |
Constructs an instance of FilterDoubleRule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FilterDoubleRule(
FilterableValueProvider valueProvider,
FilterNumericRuleEvaluator evaluator,
double ruleValue,
double epsilon
)
Parameters
- valueProvider FilterableValueProvider
- A pointer to a "value provider" object that will extract values from a Revit document.
- evaluator FilterNumericRuleEvaluator
- A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
- ruleValue Double
- The user-supplied value against which values from a Revit document will be tested.
- epsilon Double
- The tolerance within which two floating-point values may be considered equal.

Exception | Condition |
---|---|
ArgumentException | The given value for ruleValue is not finite -or- The given value for ruleValue is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number |
ArgumentNullException | A non-optional argument was null |