RemoveAddInCommandBinding Method


Removes an AddInCommandBinding.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveAddInCommandBinding(
	RevitCommandId revitCommandId
)
Visual Basic
Public Sub RemoveAddInCommandBinding ( _
	revitCommandId As RevitCommandId _
)
Visual C++
public:
void RemoveAddInCommandBinding(
	RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UIRevitCommandId
The Revit command id to identify the command handler you want to remove the binding.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when uiApplication or revitCommandId is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the given command is not bound with this add-in.

See Also