GetDockablePane Method


Gets a DockablePane object by its ID.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DockablePane GetDockablePane(
	DockablePaneId id
)
Visual Basic
Public Function GetDockablePane ( _
	id As DockablePaneId _
) As DockablePane
Visual C++
public:
DockablePane^ GetDockablePane(
	DockablePaneId^ id
)

Parameters

id
Type: Autodesk.Revit.UIDockablePaneId
Unique identifier for the new pane.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if no dockable pane has been registered with identifier %id%.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the dockable pane with identifier %id% has not been created yet.

See Also