GetDockablePane Method


UIControlled Application Get Dockable Pane Method

Gets a DockablePane object by its ID.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DockablePane GetDockablePane(
	DockablePaneId id
)

Parameters

id DockablePaneId
Unique identifier for the new pane.

Return Value

DockablePane
Exceptions
Exception Condition
ArgumentException Thrown if no dockable pane has been registered with identifier %id%.
ArgumentException Thrown if the dockable pane with identifier %id% has not been created yet.
See Also