Checks if the reference provided can be used in creating Rebar constraints
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetReference
- Type: Autodesk.Revit.DBReference
The reference to be checked
Return Value
returns true if reference can be used in a constraint, false otherwiseRemarks
Reference is valid if it points to an uncut face of a structural that can host rebar.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |