Adds a new filter at the specified position in the list.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filter
- Type: Autodesk.Revit.DBScheduleFilter
The filter to add.
- index
- Type: SystemInt32
The index in the list of filters.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | index is not a valid insert position. |
Autodesk.Revit.ExceptionsInvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8. |