InsertFilter Method


Schedule Definition Insert Filter Method

Adds a new filter at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void InsertFilter(
	ScheduleFilter filter,
	int index
)

Parameters

filter ScheduleFilter
The filter to add.
index Int32
The index in the list of filters.
Exceptions
Exception Condition
ArgumentException The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException index is not a valid insert position.
InvalidOperationException This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8.
See Also