Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- leadingSpaces
- Type: SystemInt32
The number of spaces to include before the parameter value.
- prefix
- Type: SystemString
The prefix to include before the parameter value.
- labelType
- Type: Autodesk.Revit.DBLabelType
The parameter value to be shown.
- suffix
- Type: SystemString
The suffix to include after the parameter value.
- formatOptions
- Type: Autodesk.Revit.DBFormatOptions
The format options to use for the parameter value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |