Dimension |
Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public DimensionEqualityLabelFormatting(
int leadingSpaces,
string prefix,
LabelType labelType,
string suffix,
FormatOptions formatOptions
)
Parameters
- leadingSpaces Int32
- The number of spaces to include before the parameter value.
- prefix String
- The prefix to include before the parameter value.
- labelType LabelType
- The parameter value to be shown.
- suffix String
- The suffix to include after the parameter value.
- formatOptions FormatOptions
- The format options to use for the parameter value.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |