GetPipeScheduleId Method


Returns an existing pipe schedule type with the same name.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static ElementId GetPipeScheduleId(
	Document doc,
	string name
)
Visual Basic
Public Shared Function GetPipeScheduleId ( _
	doc As Document, _
	name As String _
) As ElementId
Visual C++
public:
static ElementId^ GetPipeScheduleId(
	Document^ doc, 
	String^ name
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document
name
Type: SystemString
The name of requested schedule type.

Return Value

Returns the element id of request schedule type, or invalidElementId if the name is not found.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also