GetPipeScheduleId Method


Pipe Schedule Type Get Pipe Schedule Id Method

Returns an existing pipe schedule type with the same name.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId GetPipeScheduleId(
	Document doc,
	string name
)

Parameters

doc Document
The document
name String
The name of requested schedule type.

Return Value

ElementId
Returns the element id of request schedule type, or invalidElementId if the name is not found.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also