IsLoadCaseSubcategoryId Method


Checks whether provided element ID refer to subcategory of Structural Load Cases (OST_LoadCases) category - one of built-in or user defined.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsLoadCaseSubcategoryId(
	ElementId loadCaseSubcategoryId
)
Visual Basic
Public Function IsLoadCaseSubcategoryId ( _
	loadCaseSubcategoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsLoadCaseSubcategoryId(
	ElementId^ loadCaseSubcategoryId
)

Parameters

loadCaseSubcategoryId
Type: Autodesk.Revit.DBElementId
The ID to check.

Return Value

True if the ID refers to load case category element, false otherwise.

Remarks

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also