Creates a new opening in a beam, brace and column.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- famInstElement
- Type: Autodesk.Revit.DBElement
host element of the opening, can be a beam, brace and column.
- profile
- Type: Autodesk.Revit.DBCurveArray
profile of the opening.
- iFace
- Type: Autodesk.Revit.CreationeRefFace
face on which opening is based on.
Return Value
If successful, an Opening object is returned.Remarks
This method forms opening on a beam, brace and column.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown if the family instance element does not exist in the given document. |