Document New |
Creates a new opening in a beam, brace and column.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public Opening NewOpening(
Element famInstElement,
CurveArray profile,
eRefFace iFace
)
Parameters
- famInstElement Element
- host element of the opening, can be a beam, brace and column.
- profile CurveArray
- profile of the opening.
- iFace eRefFace
- face on which opening is based on.
Return Value
OpeningIf successful, an Opening object is returned.

Exception | Condition |
---|---|
ArgumentException | Thrown if the family instance element does not exist in the given document. |

This method forms opening on a beam, brace and column.