GetOrCreateRebarContainerType Method


Creates or returns a RebarContainerType object with a given name.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static ElementId GetOrCreateRebarContainerType(
	Document aDoc,
	string name
)
Visual Basic
Public Shared Function GetOrCreateRebarContainerType ( _
	aDoc As Document, _
	name As String _
) As ElementId
Visual C++
public:
static ElementId^ GetOrCreateRebarContainerType(
	Document^ aDoc, 
	String^ name
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document.
name
Type: SystemString
Name of the type.

Return Value

The type id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException name is an empty string.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also