SetCopingIds Method


Specifies the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SetCopingIds(
	ICollection<ElementId> cutters
)
Visual Basic
Public Function SetCopingIds ( _
	cutters As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool SetCopingIds(
	ICollection<ElementId^>^ cutters
)

Parameters

cutters
Type: System.Collections.GenericICollectionElementId
A set of coping cutters (steel beams and steel columns).

Remarks

The set may be a null reference (Nothing in Visual Basic) or empty, but may not contain the element being coped.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown when 'cutters' contains this instance.
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when regeneration fails or if a cutter element is not a FamilyInstance.

See Also