SetCopingIds Method


Family Instance Set Coping Ids Method

Specifies the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SetCopingIds(
	ICollection<ElementId> cutters
)

Parameters

cutters ICollection ElementId
A set of coping cutters (steel beams and steel columns).

Return Value

Boolean
Exceptions
Exception Condition
ArgumentException Thrown when 'cutters' contains this instance.
InvalidOperationException Thrown when regeneration fails or if a cutter element is not a FamilyInstance.
Remarks
The set may be or empty, but may not contain the element being coped.
See Also