Create Method


Creates a new instance of a wall attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static FaceWall Create(
	Document document,
	ElementId wallType,
	WallLocationLine locationLine,
	Reference faceReference
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	wallType As ElementId, _
	locationLine As WallLocationLine, _
	faceReference As Reference _
) As FaceWall
Visual C++
public:
static FaceWall^ Create(
	Document^ document, 
	ElementId^ wallType, 
	WallLocationLine locationLine, 
	Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
wallType
Type: Autodesk.Revit.DBElementId
The wall type. This must be a wall type accepted by IsWallTypeValidForFaceWall()
locationLine
Type: Autodesk.Revit.DBWallLocationLine
The alignment of the wall location line.
faceReference
Type: Autodesk.Revit.DBReference
The reference from the massing face. This must pass IsValidFaceReferenceForFaceWall()

Return Value

The newly created face wall.

Remarks

This method will regenerate the document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element wallType does not exist in the document -or- document is not a project document. -or- This wall type cannot be applied to a face wall. -or- This reference cannot be applied to a face wall.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException During a dynamic update, the newly created face wall is going to be joined to surrounding structures.
Autodesk.Revit.ExceptionsInvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited.
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also