Face |
Creates a new instance of a wall attached to a non-vertical massing face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FaceWall Create(
Document document,
ElementId wallType,
WallLocationLine locationLine,
Reference faceReference
)
Parameters
- document Document
- The document.
- wallType ElementId
- The wall type. This must be a wall type accepted by IsWallTypeValidForFaceWall()
- locationLine WallLocationLine
- The alignment of the wall location line.
- faceReference Reference
- The reference from the massing face. This must pass IsValidFaceReferenceForFaceWall()
Return Value
FaceWallThe newly created face wall.

Exception | Condition |
---|---|
ArgumentException | The element wallType does not exist in the document -or- document is not a project document. -or- This wall type cannot be applied to a face wall. -or- This reference cannot be applied to a face wall. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
ForbiddenForDynamicUpdateException | During a dynamic update, the newly created face wall is going to be joined to surrounding structures. |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

This method will regenerate the document.