AddLoadClassification Method


Add a Load Classification Id to the array of Load Classifications.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool AddLoadClassification(
	ElementId loadClassficationId
)
Visual Basic
Public Function AddLoadClassification ( _
	loadClassficationId As ElementId _
) As Boolean
Visual C++
public:
bool AddLoadClassification(
	ElementId^ loadClassficationId
)

Parameters

loadClassficationId
Type: Autodesk.Revit.DBElementId
The load classification to add

Return Value

True if success; false if the given Id has already existed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also