Gets the extendable region ids for the compound structure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- top
- Type: SystemBoolean
If true, retrieve ids of regions which are extendable at the top, otherwise retrieve the ids of regions which are extendable at the bottom.
Return Value
An array of region ids which are marked extendable.Remarks
Regions along the top or bottom of the wall may be set to be extendable.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | This operation is valid only for vertically compound structures. |