GetExtendableRegionIds Method


Compound Structure Get Extendable Region Ids Method

Gets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<int> GetExtendableRegionIds(
	bool top
)

Parameters

top Boolean
If true, retrieve ids of regions which are extendable at the top, otherwise retrieve the ids of regions which are extendable at the bottom.

Return Value

IList Int32
An array of region ids which are marked extendable.
Exceptions
Exception Condition
InvalidOperationException This operation is valid only for vertically compound structures.
Remarks
Regions along the top or bottom of the wall may be set to be extendable.
See Also