Insert a waypoint at the specified index
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.2
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- waypoint
- Type: Autodesk.Revit.DBXYZ
The waypoint to insert.
- index
- Type: SystemInt32
The index to insert the waypoint at.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Index is invalid for an existing or new waypoint for this path. -or- This functionality is not available in Revit LT. -or- Cannot perform this operation for a path of travel in a group. |