InsertWaypoint Method


Path Of Travel Insert Waypoint Method

Insert a waypoint at the specified index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void InsertWaypoint(
	XYZ waypoint,
	int index
)

Parameters

waypoint XYZ
The waypoint to insert.
index Int32
The index to insert the waypoint at.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Index is invalid for an existing or new waypoint for this path. -or- This functionality is not available in Revit LT. -or- Cannot perform this operation for a path of travel in a group.
See Also