Gets the Green Building Studio identifier associated with the construction.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- massSurfaceSubCategoryId
- Type: Autodesk.Revit.DBElementId
The ElementId of a valid Mass subcategory of a MassSurfaceData.
Return Value
Returns the integer id used to represent the ConceptualConstructionType.Remarks
Sometimes the GBSId is different for the same ConceptualConstructionType depending on the mass subcategory it is related to. This is usually the case, for example, for window and skylight constructions, which do not share GBSid's even when they share ConceptualConstructionTypes.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input Element massSurfaceSubCategoryId is not a valid subcategory value for MassSurfaceData. -or- The ElementId massSurfaceSubCategoryId is not appropriate for this ConceptualConstructionType. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |