Conceptual |
Gets the Green Building Studio identifier associated with the construction.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- massSurfaceSubCategoryId ElementId
- The ElementId of a valid Mass subcategory of a MassSurfaceData.
Return Value
Int32Returns the integer id used to represent the ConceptualConstructionType.

Exception | Condition |
---|---|
ArgumentException | The input Element massSurfaceSubCategoryId is not a valid subcategory value for MassSurfaceData. -or- The ElementId massSurfaceSubCategoryId is not appropriate for this ConceptualConstructionType. |
ArgumentNullException | A non-optional argument was null |

Sometimes the GBSId is different for the same ConceptualConstructionType depending on the mass subcategory it is related to. This is usually the case, for example, for window and skylight constructions, which do not share GBSid's even when they share ConceptualConstructionTypes.