Checks whether a field can be used with a HasParameter filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldId
- Type: Autodesk.Revit.DBScheduleFieldId
The ID of the field to check.
Return Value
True if the field can be used with a HasParameter filter, false otherwise.Remarks
The HasParameter filter type only supports shared parameters, and only with the Instance or ElementType field types.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | fieldId is not the ID of a field in this ScheduleDefinition. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |