CanFilterByParameterExistence Method


Schedule Definition Can Filter By Parameter Existence Method

Checks whether a field can be used with a HasParameter filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanFilterByParameterExistence(
	ScheduleFieldId fieldId
)

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a HasParameter filter, false otherwise.
Exceptions
Exception Condition
ArgumentException fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException A non-optional argument was null
Remarks
The HasParameter filter type only supports shared parameters, and only with the Instance or ElementType field types.
See Also