ElementStructuralTypeFilter Constructor (StructuralType)


Constructs a new instance of a filter to match elements by structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public ElementStructuralTypeFilter(
	StructuralType structuralType
)
Visual Basic
Public Sub New ( _
	structuralType As StructuralType _
)
Visual C++
public:
ElementStructuralTypeFilter(
	StructuralType structuralType
)

Parameters

structuralType
Type: Autodesk.Revit.DB.StructureStructuralType
The structural type to match.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also