ElementStructuralTypeFilter Constructor (StructuralType)


Element Structural Type Filter(Structural Type) Constructor

Constructs a new instance of a filter to match elements by structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementStructuralTypeFilter(
	StructuralType structuralType
)

Parameters

structuralType StructuralType
The structural type to match.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also