GetAddInNameFromDocument Method


name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public string GetAddInNameFromDocument(
	Document aDoc
)
Visual Basic
Public Function GetAddInNameFromDocument ( _
	aDoc As Document _
) As String
Visual C++
public:
String^ GetAddInNameFromDocument(
	Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
target document

Return Value

name of application

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was NULL

See Also