GetAddInNameFromDocument Method


Add In Id Get Add In Name From Document Method

name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetAddInNameFromDocument(
	Document aDoc
)

Parameters

aDoc Document
target document

Return Value

String
name of application
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was NULL
See Also