SetSegments Method


Sets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetSegments(
	IList<LinePatternSegment> lineSegs
)
Visual Basic
Public Sub SetSegments ( _
	lineSegs As IList(Of LinePatternSegment) _
)
Visual C++
public:
void SetSegments(
	IList<LinePatternSegment^>^ lineSegs
)

Parameters

lineSegs
Type: System.Collections.GenericIListLinePatternSegment
The sequence of segments.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also