SetHookPermission Method


Identifies if a hook type is permitted for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetHookPermission(
	ElementId hookId,
	bool permission
)
Visual Basic
Public Sub SetHookPermission ( _
	hookId As ElementId, _
	permission As Boolean _
)
Visual C++
public:
void SetHookPermission(
	ElementId^ hookId, 
	bool permission
)

Parameters

hookId
Type: Autodesk.Revit.DBElementId
id of the hook type
permission
Type: SystemBoolean
True if the hook type should be permitted for this bar type, otherwise false

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException the rebar hook type id hookId is not valid
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also