SetHookPermission Method


Rebar Bar Type Set Hook Permission Method

Identifies if a hook type is permitted for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetHookPermission(
	ElementId hookId,
	bool permission
)

Parameters

hookId ElementId
id of the hook type
permission Boolean
True if the hook type should be permitted for this bar type, otherwise false
Exceptions
Exception Condition
ArgumentException the rebar hook type id hookId is not valid
ArgumentNullException A non-optional argument was null
See Also